# External Data Source

**URL:** https://community.nocodb.com/c/external-data-source/18.md

[Latest](https://community.nocodb.com/latest.md) · [Categories](https://community.nocodb.com/categories.md) · [Tags](https://community.nocodb.com/tags.md)

---

## [About the External Data Source category](https://community.nocodb.com/t/about-the-external-data-source-category/1188)

<div class="topic-metadata">

**Author:** [@Navi](https://community.nocodb.com/u/Navi)\
**Replies:** 0

</div>

---

## [Cannot destructure property ‘type’ of ‘t’ as it is undefined](https://community.nocodb.com/t/cannot-destructure-property-type-of-t-as-it-is-undefined/2098)

<div class="topic-metadata">

**Author:** [@joakim](https://community.nocodb.com/u/joakim)\
**Replies:** 5\
**Last updated:** [November 10, 2025, 9:29am UTC](https://community.nocodb.com/t/cannot-destructure-property-type-of-t-as-it-is-undefined/2098 "2025-11-10T09:29:58Z")

</div>

Hi guys, I get an error when I try to change the name/description/other properties of a “Link to another record” column. The error is as follows: Cannot destructure property ‘type’ of ‘t’ as it is undefined. When goog…

---

## [\[Self Hosted\] Connection Issues: Self-hosted NocoDB on Hetzner to Supabase (ENOTFOUND, Self-signed cert errors)](https://community.nocodb.com/t/self-hosted-connection-issues-self-hosted-nocodb-on-hetzner-to-supabase-enotfound-self-signed-cert-errors/2085)

<div class="topic-metadata">

**Author:** [@javibg6](https://community.nocodb.com/u/javibg6)\
**Replies:** 2\
**Last updated:** [September 25, 2025, 9:04am UTC](https://community.nocodb.com/t/self-hosted-connection-issues-self-hosted-nocodb-on-hetzner-to-supabase-enotfound-self-signed-cert-errors/2085 "2025-09-25T09:04:25Z")

</div>

Hello everyone, I’m having persistent trouble connecting my self-hosted NocoDB instance to a Supabase cloud database. I’ve followed several troubleshooting paths, including another post on this forum, but I’m now stuck. …

---

## [Importing from Airtable error: Duplicate column alias](https://community.nocodb.com/t/importing-from-airtable-error-duplicate-column-alias/2027)

<div class="topic-metadata">

**Author:** [@webjuice](https://community.nocodb.com/u/webjuice)\
**Replies:** 3\
**Last updated:** [July 28, 2025, 2:37pm UTC](https://community.nocodb.com/t/importing-from-airtable-error-duplicate-column-alias/2027 "2025-07-28T14:37:43Z")

</div>

I am trying to import a base from Airtable, but I got this error: “Duplicate column alias” I have a question about importing data from Airtable. Is it possible to have detailed logs when an error occurs? I have a “Dupli…

---

## [Automatically hide metadata columns on external data source](https://community.nocodb.com/t/automatically-hide-metadata-columns-on-external-data-source/1960)

<div class="topic-metadata">

**Author:** [@john-at-walden](https://community.nocodb.com/u/john-at-walden)\
**Replies:** 0\
**Last updated:** [June 27, 2025, 5:46am UTC](https://community.nocodb.com/t/automatically-hide-metadata-columns-on-external-data-source/1960 "2025-06-27T05:46:40Z")

</div>

I have multiple metadata columns on my table, such as: id, Created by, Created on, Updated by, Updated on, etc. Editors should not be able to see this - they should be filled in programmatically on record creation or mod…

---

## [Set up Kanban View on Postgres Logical View?](https://community.nocodb.com/t/set-up-kanban-view-on-postgres-logical-view/1928)

<div class="topic-metadata">

**Author:** [@layeonchart](https://community.nocodb.com/u/layeonchart)\
**Replies:** 2\
**Last updated:** [June 17, 2025, 10:58am UTC](https://community.nocodb.com/t/set-up-kanban-view-on-postgres-logical-view/1928 "2025-06-17T10:58:03Z")

</div>

I have treatment table which column treatment\_status I set to “Single Select” type of NocoDB. But when I join into a view table, that column turn to normal text. Therefore, I can’t set up a Kanban View on the view table.…

---

## [Mysql connector choosing wrong table index](https://community.nocodb.com/t/mysql-connector-choosing-wrong-table-index/1807)

<div class="topic-metadata">

**Author:** [@Thud1415](https://community.nocodb.com/u/Thud1415)\
**Replies:** 2\
**Last updated:** [April 16, 2025, 4:06pm UTC](https://community.nocodb.com/t/mysql-connector-choosing-wrong-table-index/1807 "2025-04-16T16:06:18Z")

</div>

Hi, I’ve connected NoCoDb to an external mysql database, but it seems to be using the wrong field as the identifier. The table looks like this: mysql\> describe customers; +----------------------+--------------+------+…

---

## [Nc\_order problems after loading DB on another account](https://community.nocodb.com/t/nc-order-problems-after-loading-db-on-another-account/1797)

<div class="topic-metadata">

**Author:** [@piotrmajewski](https://community.nocodb.com/u/piotrmajewski)\
**Replies:** 5\
**Last updated:** [April 14, 2025, 5:09am UTC](https://community.nocodb.com/t/nc-order-problems-after-loading-db-on-another-account/1797 "2025-04-14T05:09:54Z")

</div>

Hi, I’ve connected PostgreSQL DB I’ve created for a client to his account without using Share option - normally as a external source. It recognized table links - even many to many but ordering is not working. nc\_order c…

---

## [NocoDB cloud - Create connection is grey](https://community.nocodb.com/t/nocodb-cloud-create-connection-is-grey/1723)

<div class="topic-metadata">

**Author:** [@aurelien\_chaumet](https://community.nocodb.com/u/aurelien_chaumet)\
**Replies:** 7\
**Last updated:** [March 18, 2025, 9:31am UTC](https://community.nocodb.com/t/nocodb-cloud-create-connection-is-grey/1723 "2025-03-18T09:31:47Z")

</div>

HI ! I’m trying to connect a personal Postgres database in the cloud app NocoDB. I wrote every parameters in the integration part, clicked on Test connection, and nothing else appears. I can’t click on Create connection…

---

## [Meta-Sync Stuck in Loading – Self-Hosted NocoDB (v0.258.2) with Postgres](https://community.nocodb.com/t/meta-sync-stuck-in-loading-self-hosted-nocodb-v0-258-2-with-postgres/1711)

<div class="topic-metadata">

**Author:** [@fran](https://community.nocodb.com/u/fran)\
**Replies:** 1\
**Last updated:** [March 17, 2025, 7:04am UTC](https://community.nocodb.com/t/meta-sync-stuck-in-loading-self-hosted-nocodb-v0-258-2-with-postgres/1711 "2025-03-17T07:04:09Z")

</div>

Issue: I’m experiencing an issue with meta-sync not working in my self-hosted NocoDB (v0.258.2) connected to a PostgreSQL database. The database contains 23 tables, about half of which were created directly in PostgreSQL…

---

## [Cannot read properties of undefined (reading 'bold')](https://community.nocodb.com/t/cannot-read-properties-of-undefined-reading-bold/1542)

<div class="topic-metadata">

**Author:** [@lolkindello](https://community.nocodb.com/u/lolkindello)\
**Replies:** 1\
**Last updated:** [December 17, 2024, 4:52am UTC](https://community.nocodb.com/t/cannot-read-properties-of-undefined-reading-bold/1542 "2024-12-17T04:52:03Z")

</div>

Hi! I try to connect to postgres but get same error in cloud and selfhosted version. Help please.

---

## [Meta sync not completing when columns of external DB are updated outside of NocoDB](https://community.nocodb.com/t/meta-sync-not-completing-when-columns-of-external-db-are-updated-outside-of-nocodb/1518)

<div class="topic-metadata">

**Author:** [@BTruper](https://community.nocodb.com/u/BTruper)\
**Replies:** 3\
**Last updated:** [December 9, 2024, 7:57am UTC](https://community.nocodb.com/t/meta-sync-not-completing-when-columns-of-external-db-are-updated-outside-of-nocodb/1518 "2024-12-09T07:57:46Z")

</div>

The meta sync is stuck on loading state for 1 day and the nocodb fails to load the updated table because of that. A workaround is to disconnect and reconnect the external data source but this results in all our ‘Views’ …

---

## [Visualisation in nocodb changes time use](https://community.nocodb.com/t/visualisation-in-nocodb-changes-time-use/1432)

<div class="topic-metadata">

**Author:** [@hugoo\_souza10](https://community.nocodb.com/u/hugoo_souza10)\
**Replies:** 1\
**Last updated:** [October 18, 2024, 10:47pm UTC](https://community.nocodb.com/t/visualisation-in-nocodb-changes-time-use/1432 "2024-10-18T22:47:23Z")

</div>

Hello, everyone. What’s up? I’m consuming a schema from the postgres database in nocodb, all the data is correct, except the dates which are in datetime format, I believe it always changes the time zone, can I somehow g…

---

## [Omission of joining tables](https://community.nocodb.com/t/omission-of-joining-tables/1276)

<div class="topic-metadata">

**Author:** [@sbrenner](https://community.nocodb.com/u/sbrenner)\
**Replies:** 1\
**Last updated:** [July 17, 2024, 6:53am UTC](https://community.nocodb.com/t/omission-of-joining-tables/1276 "2024-07-17T06:53:53Z")

</div>

Hi, I am trying to use NocoDB as a simple CRUD-UI for my database. The problem I am currently facing: I have “joining tables” modelling many-to-many relationships, but with additional attributes. Classical example: “per…

---

## [I get this error: self signed certificate in certificate chain - when trying to connect to an external postgress database](https://community.nocodb.com/t/i-get-this-error-self-signed-certificate-in-certificate-chain-when-trying-to-connect-to-an-external-postgress-database/1193)

<div class="topic-metadata">

**Author:** [@erikwillekens](https://community.nocodb.com/u/erikwillekens)\
**Replies:** 1\
**Last updated:** [May 28, 2024, 4:11pm UTC](https://community.nocodb.com/t/i-get-this-error-self-signed-certificate-in-certificate-chain-when-trying-to-connect-to-an-external-postgress-database/1193 "2024-05-28T16:11:51Z")

</div>

Hello, I want to connect my postgress database on Digital Ocean to my airtable import. I choose the option to add a datasource and get the error “self signed certificate in chain”. I uploaded a certificate from digital …

---

## [Limits on external database on Cloud](https://community.nocodb.com/t/limits-on-external-database-on-cloud/1161)

<div class="topic-metadata">

**Author:** [@automationhelpers](https://community.nocodb.com/u/automationhelpers)\
**Replies:** 1\
**Last updated:** [May 23, 2024, 7:23pm UTC](https://community.nocodb.com/t/limits-on-external-database-on-cloud/1161 "2024-05-23T19:23:50Z")

</div>

If you connect to an external database on a Cloud plan, does it have the same limits as the hosted db? I.e. 300k rows/workspace on Business?
