# Self-Host

**URL:** https://community.nocodb.com/c/setup/13.md?page=1

[Latest](https://community.nocodb.com/latest.md) · [Categories](https://community.nocodb.com/categories.md) · [Tags](https://community.nocodb.com/tags.md)

**Page:** 2

---

## [Bug: \[self-hosted\] : CSV Import Fails with "This record already exists" on PostgreSQL but works on MySQL](https://community.nocodb.com/t/bug-self-hosted-csv-import-fails-with-this-record-already-exists-on-postgresql-but-works-on-mysql/2093)

<div class="topic-metadata">

**Author:** [@hengke](https://community.nocodb.com/u/hengke)\
**Replies:** 1\
**Last updated:** [September 27, 2025, 9:03am UTC](https://community.nocodb.com/t/bug-self-hosted-csv-import-fails-with-this-record-already-exists-on-postgresql-but-works-on-mysql/2093 "2025-09-27T09:03:26Z")

</div>

Description: When using the CSV import feature to update existing records in a table, PostgreSQL throws a “This record already exists” error. This error does not occur when using MySQL. Example: test table，title is PRIM…

---

## [Move table from one DB to another](https://community.nocodb.com/t/move-table-from-one-db-to-another/2083)

<div class="topic-metadata">

**Author:** [@bigboa](https://community.nocodb.com/u/bigboa)\
**Replies:** 2\
**Last updated:** [September 15, 2025, 10:47am UTC](https://community.nocodb.com/t/move-table-from-one-db-to-another/2083 "2025-09-15T10:47:45Z")

</div>

Is there any way to move table from one DB to another inside same NocoDB instance?

---

## [Show existing values in form field?](https://community.nocodb.com/t/show-existing-values-in-form-field/2078)

<div class="topic-metadata">

**Author:** [@traste](https://community.nocodb.com/u/traste)\
**Replies:** 2\
**Last updated:** [September 12, 2025, 9:54am UTC](https://community.nocodb.com/t/show-existing-values-in-form-field/2078 "2025-09-12T09:54:54Z")

</div>

Hi, I have a Postgres external DB linked to my NocoDB base. I added a form view, but I need the form field to show existing values from the table so I can select one (like a dropdown/autocomplete). Right now, I have to …

---

## [\[Self hosted\] Unknown User Appeared in My Self-Hosted NocoDB Instance](https://community.nocodb.com/t/self-hosted-unknown-user-appeared-in-my-self-hosted-nocodb-instance/2062)

<div class="topic-metadata">

**Author:** [@Devel0per](https://community.nocodb.com/u/Devel0per)\
**Replies:** 2\
**Last updated:** [August 19, 2025, 6:26am UTC](https://community.nocodb.com/t/self-hosted-unknown-user-appeared-in-my-self-hosted-nocodb-instance/2062 "2025-08-19T06:26:12Z")

</div>

I have no idea how this person managed to join my NocoDB instance. I’ve set a strong password, so it shouldn’t be possible for a stranger to access it. I removed him from the user management. he had an organization-level…

---

## [Can I change TimeZone?](https://community.nocodb.com/t/can-i-change-timezone/2053)

<div class="topic-metadata">

**Author:** [@bigboa](https://community.nocodb.com/u/bigboa)\
**Replies:** 3\
**Last updated:** [August 13, 2025, 11:46am UTC](https://community.nocodb.com/t/can-i-change-timezone/2053 "2025-08-13T11:46:18Z")

</div>

Hi, We are running self-hosted NocoDB using docker compose. We used same TZ, non UTC, for DB(PG), docker host and inside docker container with NocoDB. But when we create new record in any table column created\_at fills…

---

## [\[Self hosted\] ERROR \[AttachmentsService\] InvalidArgument: Credential access key has length 40, should be 32](https://community.nocodb.com/t/self-hosted-error-attachmentsservice-invalidargument-credential-access-key-has-length-40-should-be-32/2047)

<div class="topic-metadata">

**Author:** [@havlis23](https://community.nocodb.com/u/havlis23)\
**Replies:** 1\
**Last updated:** [August 13, 2025, 8:04am UTC](https://community.nocodb.com/t/self-hosted-error-attachmentsservice-invalidargument-credential-access-key-has-length-40-should-be-32/2047 "2025-08-13T08:04:04Z")

</div>

Hello everyone, I have a problem with uploading media to an attachment field. I’m running a self-hosted NocoDB instance, and when I try to upload a JPEG to a media field, I get the following error: Credential access k…

---

## [\[Self hosted : External DB\] When MS SQL Server - External Database - be ready for use?](https://community.nocodb.com/t/self-hosted-external-db-when-ms-sql-server-external-database-be-ready-for-use/1343)

<div class="topic-metadata">

**Author:** [@Danie](https://community.nocodb.com/u/Danie)\
**Replies:** 4\
**Last updated:** [August 12, 2025, 12:58pm UTC](https://community.nocodb.com/t/self-hosted-external-db-when-ms-sql-server-external-database-be-ready-for-use/1343 "2025-08-12T12:58:46Z")

</div>

Hi Team, To start, amazing product!! Have had good fun playing around with it. Only question I have is, when we expect to have the External DB connection to MS SQL Server active?

---

## [\[Self hosted\] Request for Free Access to Full Self-Hosted Version for a Non-Profit Organization](https://community.nocodb.com/t/self-hosted-request-for-free-access-to-full-self-hosted-version-for-a-non-profit-organization/2040)

<div class="topic-metadata">

**Author:** [@Ashot](https://community.nocodb.com/u/Ashot)\
**Replies:** 1\
**Last updated:** [August 7, 2025, 6:57am UTC](https://community.nocodb.com/t/self-hosted-request-for-free-access-to-full-self-hosted-version-for-a-non-profit-organization/2040 "2025-08-07T06:57:00Z")

</div>

I am writing on behalf of a registered non-profit organization working in the field of youth education and leadership development. We currently serve around 500 beneficiaries across different regions. While I prefer not …

---

## [Limitations with Postgres Data Reflection](https://community.nocodb.com/t/limitations-with-postgres-data-reflection/2029)

<div class="topic-metadata">

**Author:** [@karmaknight1369](https://community.nocodb.com/u/karmaknight1369)\
**Replies:** 5\
**Last updated:** [August 3, 2025, 4:40pm UTC](https://community.nocodb.com/t/limitations-with-postgres-data-reflection/2029 "2025-08-03T16:40:26Z")

</div>

Hi NocoDB team and community, We’re evaluating NocoDB for our organization but have encountered what appear to be fundamental limitations with the Postgres Data Reflection feature. These issues are potential deal-breake…

---

## [Unable to type into Formula column type](https://community.nocodb.com/t/unable-to-type-into-formula-column-type/2010)

<div class="topic-metadata">

**Author:** [@licking8882](https://community.nocodb.com/u/licking8882)\
**Replies:** 3\
**Last updated:** [July 20, 2025, 6:11pm UTC](https://community.nocodb.com/t/unable-to-type-into-formula-column-type/2010 "2025-07-20T18:11:53Z")

</div>

I’m self-hosting an instance of nocodb. I have it connected to a postgres database. I’m trying to add a formula but I am running into an issue where I can’t type into the input box. It is only allowing me to select value…

---

## [How to backup and restore everything](https://community.nocodb.com/t/how-to-backup-and-restore-everything/2006)

<div class="topic-metadata">

**Author:** [@bladed](https://community.nocodb.com/u/bladed)\
**Replies:** 1\
**Last updated:** [July 18, 2025, 1:00pm UTC](https://community.nocodb.com/t/how-to-backup-and-restore-everything/2006 "2025-07-18T13:00:35Z")

</div>

Hi to all, I am self hosting a nocodb via docker compose installation, everything is going well. I need to move everything to another remote machine, how to do this? Thank you

---

## [Can't connect to user-defined websocket with NuxtPlugin](https://community.nocodb.com/t/cant-connect-to-user-defined-websocket-with-nuxtplugin/1998)

<div class="topic-metadata">

**Author:** [@layeonchart](https://community.nocodb.com/u/layeonchart)\
**Replies:** 0\
**Last updated:** [July 10, 2025, 10:56am UTC](https://community.nocodb.com/t/cant-connect-to-user-defined-websocket-with-nuxtplugin/1998 "2025-07-10T10:56:37Z")

</div>

import type { Socket } from 'socket.io-client' import { io } from 'socket.io-client' export default defineNuxtPlugin(async (nuxtApp) =\>{ let socket: Socket let listeners: Array\<(payload: any) =\> void\> = \[\] …

---

## [Cannot access main postgres database with coolify](https://community.nocodb.com/t/cannot-access-main-postgres-database-with-coolify/1353)

<div class="topic-metadata">

**Author:** [@shady](https://community.nocodb.com/u/shady)\
**Replies:** 22\
**Last updated:** [July 10, 2025, 5:36am UTC](https://community.nocodb.com/t/cannot-access-main-postgres-database-with-coolify/1353 "2025-07-10T05:36:49Z")

</div>

I installed Noocdb on coolify. I added a postgres service to the project. Use the env variable NC\_DB with the value pg://j4g44okskok04cks4kwogkkg:5432?u=postgres&p=\<password\>&d=postgres but I am getting this error in l…

---

## [MinIO AWS Region Error When Connecting via NocoDB UI (v0.258.11)](https://community.nocodb.com/t/minio-aws-region-error-when-connecting-via-nocodb-ui-v0-258-11/1990)

<div class="topic-metadata">

**Author:** [@devika](https://community.nocodb.com/u/devika)\
**Replies:** 2\
**Last updated:** [July 8, 2025, 11:04am UTC](https://community.nocodb.com/t/minio-aws-region-error-when-connecting-via-nocodb-ui-v0-258-11/1990 "2025-07-08T11:04:51Z")

</div>

Hi Team, I am trying to configure MinIO as an S3-compatible storage backend for NocoDB (version 0.258.11). MinIO is accessible from the pod, and connections are working when tested directly. However, when I try to perfo…

---

## [Sqlite pragma settings](https://community.nocodb.com/t/sqlite-pragma-settings/1982)

<div class="topic-metadata">

**Author:** [@Mado](https://community.nocodb.com/u/Mado)\
**Replies:** 3\
**Last updated:** [July 4, 2025, 11:29am UTC](https://community.nocodb.com/t/sqlite-pragma-settings/1982 "2025-07-04T11:29:57Z")

</div>

Unfortunately I did accidently choose sqlite for our database. Now I try to tune it, that it is not that slow. There are pragma settings, which need to be appied in the running session. For example: pragma journal\_mode…

---

## [Updating on Coolify](https://community.nocodb.com/t/updating-on-coolify/1938)

<div class="topic-metadata">

**Author:** [@pfriedl](https://community.nocodb.com/u/pfriedl)\
**Replies:** 1\
**Last updated:** [June 19, 2025, 11:27am UTC](https://community.nocodb.com/t/updating-on-coolify/1938 "2025-06-19T11:27:10Z")

</div>

Hi all, I just installed NoCoDB on Coolify, and when I login I see there’s a new version. I went through the documentation and I don’t see any instructions on upgrading through Coolify. Any tutorials or walkthroughs out…

---

## [NocoDB v0.262.4 (SQLite3): DATEADD Formula Results in Empty Field - RBU Date + 28 Days](https://community.nocodb.com/t/nocodb-v0-262-4-sqlite3-dateadd-formula-results-in-empty-field-rbu-date-28-days/1749)

<div class="topic-metadata">

**Author:** [@fk\_kpt](https://community.nocodb.com/u/fk_kpt)\
**Replies:** 4\
**Last updated:** [May 29, 2025, 3:02am UTC](https://community.nocodb.com/t/nocodb-v0-262-4-sqlite3-dateadd-formula-results-in-empty-field-rbu-date-28-days/1749 "2025-05-29T03:02:11Z")

</div>

In my self-hosted NocoDB database, I have the following setup: Source field "RBU": Date field in DD/MM/YYYY format Target field: Formula field for payment receipt Formula used: DATEADD({RBU}, 28, "day") The…

---

## [Hide logo in forms (at the bottom of the forms "NocoDB Forms")](https://community.nocodb.com/t/hide-logo-in-forms-at-the-bottom-of-the-forms-nocodb-forms/1889)

<div class="topic-metadata">

**Author:** [@ceubri](https://community.nocodb.com/u/ceubri)\
**Replies:** 5\
**Last updated:** [May 26, 2025, 5:26am UTC](https://community.nocodb.com/t/hide-logo-in-forms-at-the-bottom-of-the-forms-nocodb-forms/1889 "2025-05-26T05:26:03Z")

</div>

Hello, i want to hide the logo at the bottom of the forms “NocoDB Forms” I see the doc, but which " paid plans" do I need to pay for? Thanks

---

## [Self-hosted Form : Error 503 Service Temporarily Unavailable](https://community.nocodb.com/t/self-hosted-form-error-503-service-temporarily-unavailable/1871)

<div class="topic-metadata">

**Author:** [@ceubri](https://community.nocodb.com/u/ceubri)\
**Replies:** 2\
**Last updated:** [May 21, 2025, 8:26am UTC](https://community.nocodb.com/t/self-hosted-form-error-503-service-temporarily-unavailable/1871 "2025-05-21T08:26:50Z")

</div>

Hello, Have you ever had a 503 error on a self hosted server? I have very often this error on a form. Have a nice day

---

## [Using IAM Roles with Litestream Integration](https://community.nocodb.com/t/using-iam-roles-with-litestream-integration/1885)

<div class="topic-metadata">

**Author:** [@tomato539](https://community.nocodb.com/u/tomato539)\
**Replies:** 2\
**Last updated:** [May 21, 2025, 7:50am UTC](https://community.nocodb.com/t/using-iam-roles-with-litestream-integration/1885 "2025-05-21T07:50:32Z")

</div>

Hi everyone, I’m currently using NocoDB with Litestream integration on AWS Fargate and had to create an IAM user to obtain an access key, which I then passed as an environment variable to NocoDB. However, in my company,…

---

## [How do I set a custom port for the pre-built executables?](https://community.nocodb.com/t/how-do-i-set-a-custom-port-for-the-pre-built-executables/979)

<div class="topic-metadata">

**Author:** [@ezequiel](https://community.nocodb.com/u/ezequiel)\
**Replies:** 2\
**Last updated:** [May 21, 2025, 7:32am UTC](https://community.nocodb.com/t/how-do-i-set-a-custom-port-for-the-pre-built-executables/979 "2025-05-21T07:32:04Z")

</div>

Basically the title. I’d like to use the pre-built binaries (on Linux) because that is by far the easiest way of getting it to run for me. However, Nocodb tries to use port 8080 by default, and I’m already using that. Is…

---

## [Unable to configure minio](https://community.nocodb.com/t/unable-to-configure-minio/1859)

<div class="topic-metadata">

**Author:** [@devika](https://community.nocodb.com/u/devika)\
**Replies:** 3\
**Last updated:** [May 16, 2025, 3:47am UTC](https://community.nocodb.com/t/unable-to-configure-minio/1859 "2025-05-16T03:47:38Z")

</div>

Hi Team, I am facing issues while configuring the MinIO bucket with NocoDB. I am deploying NocoDB in a self-hosted environment on Kubernetes using a Helm chart. The MinIO application is installed on the same cluster. I…

---

## [Trouble Connecting NocoDB with n8n – Unauthorized / API Not Found](https://community.nocodb.com/t/trouble-connecting-nocodb-with-n8n-unauthorized-api-not-found/1855)

<div class="topic-metadata">

**Author:** [@FrolsonDev](https://community.nocodb.com/u/FrolsonDev)\
**Replies:** 1\
**Last updated:** [May 5, 2025, 7:46am UTC](https://community.nocodb.com/t/trouble-connecting-nocodb-with-n8n-unauthorized-api-not-found/1855 "2025-05-05T07:46:16Z")

</div>

Hello, I’m currently trying to connect NocoDB and n8n, but I’m encountering issues and haven’t found a solution in the documentation or forums. Here’s my docker-compose setup for NocoDB: yaml CopierModifier nocodb: …

---

## [Case insensitive text queries?](https://community.nocodb.com/t/case-insensitive-text-queries/1833)

<div class="topic-metadata">

**Author:** [@scottharman](https://community.nocodb.com/u/scottharman)\
**Replies:** 3\
**Last updated:** [May 1, 2025, 6:23am UTC](https://community.nocodb.com/t/case-insensitive-text-queries/1833 "2025-05-01T06:23:47Z")

</div>

Hey team - via the API, how do I enforce case-insensitive text queries? Is there a way to enable this, or is it an underlying datatype issue?

---

## [The Foreign Key not display correct value seleted](https://community.nocodb.com/t/the-foreign-key-not-display-correct-value-seleted/1831)

<div class="topic-metadata">

**Author:** [@thanhlc](https://community.nocodb.com/u/thanhlc)\
**Replies:** 1\
**Last updated:** [April 30, 2025, 8:20pm UTC](https://community.nocodb.com/t/the-foreign-key-not-display-correct-value-seleted/1831 "2025-04-30T20:20:31Z")

</div>

Hi everybody, I hav the issue: I have 2 tables on the PostgresQL include: Keywords is primary table and foreign key to shoes\_line. When I choose an any keyword on table shoes\_line, this column is display incorrect dat…

---

## [RECORD\_NOT\_FOUND when updating a record using ID with n8n and NocoDB](https://community.nocodb.com/t/record-not-found-when-updating-a-record-using-id-with-n8n-and-nocodb/1810)

<div class="topic-metadata">

**Author:** [@raulinoreal](https://community.nocodb.com/u/raulinoreal)\
**Replies:** 3\
**Last updated:** [April 24, 2025, 6:53pm UTC](https://community.nocodb.com/t/record-not-found-when-updating-a-record-using-id-with-n8n-and-nocodb/1810 "2025-04-24T18:53:39Z")

</div>

Hey everyone, I could use some help with an integration using n8n and NocoDB. I’ve built a workflow in n8n that performs a GET request on a table, filters records by a specific status, then executes an action. After tha…

---

## [Paid self-hosted plan](https://community.nocodb.com/t/paid-self-hosted-plan/1812)

<div class="topic-metadata">

**Author:** [@Sai](https://community.nocodb.com/u/Sai)\
**Replies:** 1\
**Last updated:** [April 16, 2025, 2:29pm UTC](https://community.nocodb.com/t/paid-self-hosted-plan/1812 "2025-04-16T14:29:09Z")

</div>

Hello everyone! Some limitations of the free plan are getting in our way. Could you please let us know the cost of the paid solution?

---

## [Query: Updating many-to-one relationships from n8n to NocoDB](https://community.nocodb.com/t/query-updating-many-to-one-relationships-from-n8n-to-nocodb/1778)

<div class="topic-metadata">

**Author:** [@hugo](https://community.nocodb.com/u/hugo)\
**Replies:** 3\
**Last updated:** [April 7, 2025, 2:04pm UTC](https://community.nocodb.com/t/query-updating-many-to-one-relationships-from-n8n-to-nocodb/1778 "2025-04-07T14:04:29Z")

</div>

Hello community, I have a workflow in n8n that updates records in a NocoDB table, but I’m having difficulties specifically with fields that have many-to-one relationships. My scenario I have a table in NocoDB that con…

---

## [Range view in calendar](https://community.nocodb.com/t/range-view-in-calendar/1780)

<div class="topic-metadata">

**Author:** [@nokoa](https://community.nocodb.com/u/nokoa)\
**Replies:** 1\
**Last updated:** [April 7, 2025, 2:11am UTC](https://community.nocodb.com/t/range-view-in-calendar/1780 "2025-04-07T02:11:50Z")

</div>

Hi, I’m trying to use nocoDB for personal use (home managing), and I already find the product very strong, congrats to the team! One question : is the lack of “calendar range” feature in self host version intentional? O…

---

## [Is it possible to change the color of calendar events based on status?](https://community.nocodb.com/t/is-it-possible-to-change-the-color-of-calendar-events-based-on-status/1774)

<div class="topic-metadata">

**Author:** [@hugo](https://community.nocodb.com/u/hugo)\
**Replies:** 2\
**Last updated:** [April 5, 2025, 8:27am UTC](https://community.nocodb.com/t/is-it-possible-to-change-the-color-of-calendar-events-based-on-status/1774 "2025-04-05T08:27:43Z")

</div>

Hi, I have a table in NocoDB called “Appointments”, and when I view it in calendar mode, the appointments appear with a default color. I would like to know if there is a way to change the color of the events in the cale…

[Previous page](https://community.nocodb.com/c/setup/13.md)

[Next page](https://community.nocodb.com/c/setup/13.md?page=2)
