Import csv issue with a specific characters?

I setup my table on NocoDB Cloud and tested .csv import feature with a sample .csv file with few lines and it worked perfectly.
I initiated the data import with the .csv file containing all my data (3312 rows / 36 col → approximatelly 99 600 data or probably 1 000 000 characters to be import in my table) and for now more than 3-4 hours, it is still showing the messqge “parsing test2.csv”, test2.csv being my csv file with all the data.
It is normal ? how long does that takes normally ?
Thank you.

Hey, could you please the sample csv to n at nocodb ~dot- com

It should not have taken that amount. We suspect that any characters are not being handled properly.

I just sent it. thank you.

@anthony.charrieau the file that you shared had only one column under name “Headings” and some garbled content. Importing file did succeed though – one column was created with 64 records. Is this correct information?

there is one column with , to separe columns during import process
I have 3312 records (rows) in the file I shared.
and it is still processing in the NocoDB front-end:

I found some mistake in my .csv → some “,” were in some data label so automatically it was not working well.
After correction → import function in NocoDB worked well. Thank you.