Unable to upload csv file to a grid view

Hi, I have spun up my own nocodb container on a k8s cluster. It pulls up latest nocodb/nocodb image every time I redeploy. I am unable to upload a csv file to its grid view. The error says ‘Cannot read properties of null (reading ‘date_format’)’. I made sure to link the columns to destination columns, match data types, etc. I also tried putting date in various formats like mm/dd/yyyy, mm/dd/yyyy HH:mm:ss, etc. It is not working. Kindly help.

@amit.gokhale Welcome to NocoDB community!

Can you share a redacted sample of your file? Or let us know what is the format of your input. I assume you are trying to upload records from CSV to an existing table. In that case, do also let us know what was the configured date format in your dateTime field.

2024-03-11T00:00:00.000Z,Test Amit,2024-03-11T00:00:00.000Z,5000,5001,2024-03-02 12:52:59+00:00,2024-03-02 12:52:59+00:00,Amit,

This is a sample row I am trying to add. The table has a “RecordId” INT identity(1,1) PK column. I tried adding that column to the csv too - doesn’t help. The “Date” column is of type “Date” and not “DateTime”. Would that be a problem?

I also tried changing the date formats to all possible types. 2024-03-11, 2024-03-11 00:00:00, 03/11/2024, etc.

@amit.gokhale there is a bug in date field handling for using upload CSV with airtable imported bases. we will fix it soon.