Local setup problems [Jun 23]

:raising_hand_man: moi asked

Hello, I’d like to contribute et to do so, install and run nocodb locally. Should I install the project bare metal on my computer or using the docker-compose provider is easier ?

:raising_hand_man: wkw replied

lets discuss here

:raising_hand_man: wkw replied

> weird, with node 16 I could not install and it seems I had to be on node v8 to have npm install working almost properly

can you show how you installed n what kind of errors you had

:raising_hand_man: wkw replied

> It seems I also need python2. I think the documentation you gave me is used for something else

why? are you looking at development setup?

Installation - NocoDB

:raising_hand_man: moi replied

I succeed to install the backend with node 16

:raising_hand_man: moi replied

I discovered the issue passing with node8 and having some python errors

:raising_hand_man: moi replied

So I had to install pyenv et python2.7 so I could install with node 16

:raising_hand_man: moi replied

I had some node-gyp errors

:raising_hand_man: wkw replied

why node 8 …

:raising_hand_man: moi replied

an error I get suggest to use node 8 so I tried

:raising_hand_man: moi replied

maybe I missread the errors but it helped me fix it :slightly_smiling_face:

:raising_hand_man: wkw replied

do u mean npm version 8

:raising_hand_man: wkw replied

my local setup

node v16.14.0

npm v8.3.1

:raising_hand_man: wkw replied

u may try follow this

:raising_hand_man: moi replied

No, I change my node version, maybe the errors handler using the python is not compatible with node16

:raising_hand_man: moi replied

I did n 8 (n is an alternative to nvm)

:raising_hand_man: wkw replied

node 8 failed for sure

Autogenerated from discord


Join NocoDB’s community

DiscordTwitterRedditDocs