Scripts in nocodb [May 04]

:raising_hand_man: CaptainKranch asked

Hello guys, I need to use an external api with the information that I have on nocodb. It’s possible to write a python or jscript to do so? In gsheets there is an option called apps scripts that let me do so… is this possible on nocodb?

:person_tipping_hand: o1lab replied

Its not yet avaialble

:person_tipping_hand: o1lab replied

but you can use our APIs and webhooks

:raising_hand_man: CaptainKranch replied

am I able to get information from an external api and put it on nocodb with the method get using webhooks?

:raising_hand_man: CaptainKranch replied


{“msg”:“insert into "nc_hook_logs_v2" ("base_id", "created_at", "event", "execution_time", "id", "notification", "operation", "payload", "project_id", "response", "test_call", "triggered_by", "type", "updated_at") values ($1, CURRENT_TIMESTAMP, $2, $3, $4, $5, $6, $7, $8, DEFAULT, $9, $10, $11, CURRENT_TIMESTAMP) - invalid input syntax for type integer: "460.735"”}


:raising_hand_man: CaptainKranch replied

I’m getting this msg when I try to use the webhooks :confused:

:person_tipping_hand: o1lab replied

please paste your project info (right top menu)

:raising_hand_man: CaptainKranch replied

Node: v12.22.12

Arch: x64

Platform: linux

Docker: false

Database: pg

ProjectOnRootDB: true

RootDB: pg

PackageVersion: 0.90.7

:raising_hand_man: BoMBx replied

According to this error message, it means you passing the wrong type of parameter. The input need interger type (…,-2,-1,0,1,2,…) but you pass the float (460.735). Or another way, just go to change type in your field of table on database into decimal type (or type which allow floating number).

:raising_hand_man: BoMBx replied


:raising_hand_man: CaptainKranch replied

I do not think thats the issue, I created a new table with no rows tried to use the webhook to give me a notification through email but it displays the same error… I saw that in github there are some similar errors should I open an issue on github?

:person_tipping_hand: o1lab replied

please do open an issue with the details

Autogenerated from discord

Join NocoDB’s community