NocoDB tables without prefixes [Feb 14]

:raising_hand_man: emsu asked

Is there a way to have nocodb generate tables without prefixes? There’s a prefix of nc_4xc8 being generated such as “nc_4xc8__test”. I would like it to generate names such as “accounts” and “books” for an external database

:man_bald: dstala replied

emsu@discord Can you share more details about your project environment?

NocoDB : Report github issues by copying project info. - YouTube

:man_bald: dstala replied

There are 3 ways to create project over NocoDB.

Dashboard - NocoDB

(1.) Creating empty project

(2.) Connecting to external database

(3.) Creating project from Excel

(1) and (3) use a local SQLite for creating tables (NC_DB). For tables created here- NocoDB adds prefix to help differentiate between tables created across different NocoDB projects. This can’t be chopped off.

If you create a new project using option (2), any new tables added to the project will be stored using same name without any explicit prefix in the external database specified.

Hope this helps!

:raising_hand_man: emsu replied

How do I get the config from a 1 click deploy? dstala@discord

:raising_hand_man: emsu replied

I created a second database to connect as an external database on Heroku and provided the correct credentials, but even though I made it SSL Required, I’m getting an error: Connection Failure:no pg_hba.conf entry for host “3.91.7.219”, user “uvqrgmzayrfxwj”, database “dc7hl10mhflk22”, SSL off

:raising_hand_man: emsu replied

This helps though. I guess I want to use the 2nd option. Although with option 1 with heroku it created it in postgres instead of a sqlite db

:man_bald: dstala replied

Open app on Heroku. Open any project that you have created on NocoDB. On right top corner, you will find “User icon”. It has “Copy Project Info” as one of sub-menu options.

On Heroku, yes- you are right. It uses PG as RootDB [NC_DB]

:man_bald: dstala replied

On one of my Heroku instances

Node: v12.22.6

Arch: x64

Platform: linux

Docker: false

Database: pg

ProjectOnRootDB: true

RootDB: pg

PackageVersion: 0.83.2

:person_tipping_hand: o1lab replied

Try setting this env variable to true in docker container NODE_TLS_REJECT_UNAUTHORIZED

Autogenerated from discord


Join NocoDB’s community

DiscordTwitterRedditDocs