Self-hosted : Webhooks are gone

I installed the self-hosted version of nocodb on the debian12 system using docker swarm, I was using it normally for weeks, today I updated to the latest version and the Webhooks are gone, do you know what it could be?

Please mention the project info number of nocodb. And its only available for the creator/owner role - confirm you have the creator/owner role for that base.

1 Like


If you have connected your external data source in data read-only mode, we have disabled webhook tab. Instead of making it disappear, better thing would be to keep it enabled; webhook even if configured will not be triggered anyway. Will fix it in our next release

Enable data edit in your data-source if disabled. This should bring back webhook tab Connect to a Data source | NocoDB

1 Like

Thank you very much for your reply, my friend. I thought I had done some bullshit here, I built here a whole system of sectors using nocodb and the webhooks are an important part of that, I managed to make them appear here again in this same version.