GCP app engine [Aug 19]

:raising_hand_man: Philipp Tsipman asked

Hi all - looking for some technical help!

Has anyone had luck deploying NocoDB to Google Cloud App Engine as a Node app?

I am quite close. It works great on my local machine, but it does not work when I deploy it to GCloud. I see a response in my browser “Cannot GET /dashboard”

Details:

The Node app and the NocoDB Database are part of the same Google Cloud project. Here’s how I currently specify the database to use as an environmental variable in app.yaml:

env_variables:

NC_DB: ‘pg://[DATABASE INSTANCE PUBLIC IP]]?u=[MYUSER]&p=[MYPASSWORD]]&d=[DATABASE NAME]’

I believe I may need to specify the NocoDB database in a format different from the instance’s public IP address. But stuck here.

Would appreciate any help from the team. Thank you!

:person_tipping_hand: o1lab replied

I think with cloud SQL some socket param’s have to be set

:person_tipping_hand: o1lab replied

pls see if you can get a sample node app working with knex before

:person_tipping_hand: o1lab replied

then it can be worked backwards

:raising_hand_man: Philipp Tsipman replied

Thank you! I’m closer.

Google App Engine connects to SQL via Unix Sockets rather than TCP. So, I switched to a Knex JSON file format to write out the full host. Like this:

app.yaml

env_variables:

NC_DB_JSON_FILE: ‘./dbconnect.json’

dbconnect.json

{

“client”: “pg”,

“connection”: {

“host” : “/cloudsql/project:region:instance”,

“user” : “my_user”,

“password” : “my_password”,

“database” : “db_name”

}

}

(Source: Manage database connections  |  Cloud SQL for PostgreSQL  |  Google Cloud)

Now, I can log in and can see my NocoDB project and tables. Yay.

However, none of the table data is showing. Every table times out.

To be continued…

:raising_hand_man: Philipp Tsipman replied

I can see the table names and table column names. But, the data is not showing:

“A :: KnexTimeoutError: Knex: Timeout acquiring a connection. The pool is probably full. Are you missing a .transacting(trx) call?”

:raising_hand_man: Philipp Tsipman replied

Any advice?

:person_tipping_hand: o1lab replied

Are u doing from gae or cloud run

:person_tipping_hand: o1lab replied

With cloud run thr were issues related to pool

:person_tipping_hand: o1lab replied

However I cannot see anything specific from our end

:person_tipping_hand: o1lab replied

Could you also try setting pool connection limits

:person_tipping_hand: o1lab replied

In your config

:person_tipping_hand: o1lab replied

Pls lookup knex

:person_tipping_hand: o1lab replied

For it

Autogenerated from discord


Join NocoDB’s community

DiscordTwitterRedditDocs